Всего на сайте:
303 тыс. 117 статей

Главная | Математика

Этапы работ при решении задач линейного программирования.  Просмотрен 42

1. Выбор и постановка задачи.

2. Составление математической модели.

3. Решение задачи в СППР.

4. После получения решения проводится анализ. Виды анализа: анализ решения, анализ устойчивости, анализ пределов.

5. Принятие оптимального решения – решение принимает не компьютер, а тот человек, который должен отвечать за результаты принятого решения.

Сочетание различных элементов модели образуют различные классы задач оптимизации, которые требуют разных методов решения.

Рассмотрим решение задач линейного программирования в MS EXCEL.

Пример 32. Фабрика выпускает два типа красок: для внутренних (I) и наружных (Е) работ. Продукция обоих видов поступает в оптовую продажу. Для производства красок используются два исходных продукта А и В. Максимально возможные суточные запасы этих продуктов составляют 6 и 8 тонн, соответственно. Расходы продуктов А и В на 1 т соответствующих красок приведены в табл. 41.

Таблица 41

Исходные данные задачи о планировании производства красок

Исходный продукт   Расход исходных продуктов на тонну краски, т Максимально возможный запас, т    
краска Е   Краска I    
А В   

 

Изучение рынка сбыта показало, что суточный спрос на краску I никогда не превышает спроса на краску Е более чем на 1 т. Кроме того, установлено, что спрос на краску I никогда не превышает 2 т в сутки. Оптовые цены одной тонны красок равны: 3000 руб. для краски Е и 2000 руб. для краски I. Какое количество краски каждого вида должна производить фабрика, чтобы доход от реализации продукции был максимальным?

Решение.

В нашем случае фабрике необходимо спланировать объем производства красок так, чтобы максимизировать прибыль. Переменными являются:

XI – суточный объем производства краски I и XE – суточный объем производства краски Е.

Суммарная суточная прибыль от производства XI краски I и XE краски Е равна

Z = 3000*XE + 2000* XI.

Целью фабрики является определение среди всех допустимых значений XE и XI таких, которые максимизируют суммарную прибыль, т. е. целевую функцию Z.

Перейдем к ограничениям, которые налагаются на XE и XI. Объем производства красок не может быть отрицательным, следовательно:

XE, XI>=0.

Расход исходного продукта для производства обоих видов красок не может превышать максимально возможный запас данного исходного продукта, следовательно:

XE+2XI<=6,

2XE+XI<=8.

Кроме того, ограничения на величину спроса на краски таковы:

XI-XE<=1,

XI<=2.

Таким образом, математическая модель данной задачи имеет следующий вид:

максимизировать

Z=3000*XE+2000*XI,

при следующих ограничениях:

XE+2*XI<=6,

2*XE+XI<=8,

XI-XE<=1,

XI<=2,

XI,XE>=0.

Данная модель является линейной, т. к. целевая функция и ограничения линейно зависят от переменных.

На листе книги создадим таблицу Исходные данные и отведем диапазон ячеек под решение (рис. 23).

 

Рис. 23. Диапазоны, отведенные под исходные данные

 

В ячейку D13 введем функцию цели = E4*C11+E5*D11

В ячейки D16: D19 соответственно

=C11+C4*D11

=B5*C11+D11

=D11-C11

=D11

В ячейки С11, D11 введем начальные значения, т. е. нулевые значения.

После этого выберем командуСервис, Поиск решения (Tools, Solver) и заполним открывшееся диалоговое окноПоиск решения (Solver), как показано на рис. 24.

Рис. 24. Диалоговое окноПоиск решения задачи о планировании производства красок

После нажатия кнопкиВыполнить (Solve) открывается окноРезультаты поиска решения (Solver Results), которое сообщает, что решение найдено (рис. 25).

 

 

Рис. 25. Диалоговое окно Результаты поиска решения

 

Результаты расчета нашей задачи (оптимальный план производства и соответствующая ему прибыль) представлены на рис. 23. Как видно из рисунка, оптимальным является производство 3,33 т краски Е и 1,33 т. краски I в сутки. Этот объем производства принесет фабрике 12666,66 тыс. руб. прибыли.

Пример 33. Фирма имеет 4 фабрики и 5 центров распределения ее товаров. Фабрики фирмы располагаются в А1, А2, А3 и А4 с производственными возможностями 200, 150, 225 и 175 единиц продукции ежедневно, соответственно. Центры распределения товаров фирмы располагаются в В1, В2, В3, В4 и В5 с потребностями в 100, 200, 50, 250 и 150 единиц продукции ежедневно, соответственно. Стоимость перевозки единицы продукции с фабрик в пункты распределения приведена в табл. 42.

Таблица 42

Транспортные расходы

  В1 В2 В3 В4 В5
А1 1,5 1,75 2,25 2,25
А2 2,5 1,75 1,5
А3 1,5 1,5 1,75 1,75
А4 0,5 1,75 1,75 1,75

Необходимо так спланировать перевозки, чтобы минимизировать суммарные транспортные расходы.

Решение.

Неизвестные в данной задаче должны удовлетворять следующим ограничениям:

– объемы перевозок не могут быть отрицательными;

– так как модель закрытая (суммарный объем произведенной продукции равен суммарному объему потребностей в ней), то вся продукция должна быть вывезена с фабрик, а потребности всех центров распределения должны быть полностью удовлетворены

Для решения этой задачи с помощью средства поиска решений введем данные, как показано на рис. 26.

В ячейки А4:F8 введены стоимости перевозок.

Ячейки B12:F15 отведены под значения неизвестных (объемы перевозок).

В ячейки H12:H15 введены объемы производства на фабриках, а в ячейки B17:F17 введена потребность в про­дукции в пунктах распределения.

В ячейку G16 введена целевая функция:

=СУММПРОИЗВ(B5:F8;B12:F15).

 

Рис. 26.Исходные данные транспортнойзадачи

В ячейки B16:F16 введены формулы, определяющие объем продукции, ввозимой в центры распределения

=СУММ(B12:B15)

=СУММ(C12:C15)

=СУММ(D12:D15)

=СУММ(E12:E15)

=СУММ(F12:F15).

В ячейки G13:G15 введены формулы вычисляющие объем продукции, вывозимой с фабрик.

=СУММ(B12:F12)

=СУММ(B13:F13)

=СУММ(B14:F14)

=СУММ(B15:F15).

Затем выберем командуСервис, Поиск решения и заполним открывшееся диалоговое окноПоиск решения, как показано на рис. 27.

 

Рис. 27.Диалоговое окно Поиск решениядля транспортной задачи

 

В диалоговом окнеПараметры поиска решениянеобходимо установить флажокЛинейная модель. После нажатия кнопкиВыполнить средство поиска решений находит оптимальный план поставок продукции и соответствующие ему транспортные расходы (рис. 28).

 

Рис. 28.Оптимальное решение транспортной задачи

 

Предыдущая статья:Задания для самостоятельной работы Следующая статья:Задание для самостоятельной работы
page speed (0.0147 sec, direct)